0°

易语言指定文本内容显示到超级列表框里

易语言 把下面的文本内容 显示到 超级列表框里 该怎么写

下面是 D:\易语言\怪物.txt 的内容

总数量=24

鸡,正常攻击,尸体割肉

鹿,正常攻击,尸体割肉

稻草人,正常攻击,不作处理

蛤蟆,正常攻击,不作处理

多钩猫,正常攻击,不作处理

钉耙猫,正常攻击,不作处理

食人花,正常攻击,不作处理

半兽人,正常攻击,不作处理

半兽战士,正常攻击,不作处理

森林雪人,正常攻击,不作处理

半兽勇士,正常攻击,不作处理

毒蜘蛛,正常攻击,不作处理

羊,正常攻击,尸体割肉

山洞蝙蝠,优先攻击,不作处理

蝎子,不 攻 击,不作处理

洞蛆,正常攻击,不作处理

楔蛾,正常攻击,不作处理

骷髅,正常攻击,不作处理

掷斧骷髅,正常攻击,不作处理

骷髅战士,正常攻击,不作处理

骷髅战将,正常攻击,不作处理

骷髅精灵,优先攻击,不作处理

僵尸,正常攻击,不作处理

尸王,优先攻击,不作处理

源码开始:

版本 2

.支持库 iext

.子程序 _按钮1_被单击

.局部变量 文本, 文本型, , “0”

.局部变量 N, 整数型

文本 = 分割文本 (到文本 (读入文件 (“D:\易语言\怪物.txt”)), #换行符, )

.如果真 (取数组成员数 (文本) > 0)

.计次循环首 (取数组成员数 (文本), N)

超级列表框1.插入表项 (, 文本 [N], , , , )

.计次循环尾 ()版本 2

.支持库 iext

.子程序 _按钮1_被单击

.局部变量 文本, 文本型, , “0”

.局部变量 N, 整数型

文本 = 分割文本 (到文本 (读入文件 (“D:\易语言\怪物.txt”)), #换行符, )

.如果真 (取数组成员数 (文本) > 0)

.计次循环首 (取数组成员数 (文本), N)

超级列表框1.插入表项 (, 文本 [N], , , , )

.计次循环尾 ()

0 条回复 A 作者 M 管理员
    所有的伟大,都源于一个勇敢的开始!
欢迎您,新朋友,感谢参与互动!欢迎您 {{author}},您在本站有{{commentsCount}}条评论